BlockSecureFlag

手机升级到QQ最新版,发现推出了闪照功能,查看闪照时禁止截图,查了下实际是加了WindowManager.LayoutParams.FLAG_SECURE标志,so,写了个xposed模块干掉他.

Xposed模块地址在这:http://repo.xposed.info/module/com.lanyus.blocksecureflag
源代码在这:https://github.com/ilanyu/BlockSecureFlag
apk文件在https://github.com/ilanyu/BlockSecureFlag/releases或者Xposed的模块地址都能下载到

下载安装后到xposed安装器中启用模块,勾选需要阻止添加WindowManager.LayoutParams.FLAG_SECURE标志的app,这里需要注意下支付宝、网上银行类的app不建议拦截,像支付宝里的付款码,商家拿到后,直接就能扣费,不需要用户这边的确认.

标签: none

已有 34 条评论

  1. nobody nobody

    友情提示orz github编译的apk 地址最后面releases(还有个s)

    1. @nobody
      感谢,已修改

  2. sunny sunny

    看了楼主的很多博客,觉得楼主绝对的人才啊! 破解的路上很牛,是黑客么? 我是个程序员,希望和楼主交个朋友,平时多学习。相互交流

    1. sunny sunny

      @sunny 加我好友啊 哈 楼主。 微信,qq 都可以 87588397

      1. @sunny
        然而这网站上留了我QQ和微信的

  3. chan chan

    小米因为系统问题,按着屏幕时没法音量键加菜单键截屏

    1. 小米测试可用,我这截图是音量下+电源键

  4. 123456 123456

    然而不能用呢

  5. 在PurifyOS团队给出的Xposed SDK25 Arm64中无法打开程序界面

  6. CK CK

    更新了一下源碼,可安裝在android 7.0/7.1/8.0

    https://github.com/ckldev/BlockSecureFlag/blob/master/app/src/main/java/com/lanyus/blocksecureflag/MainActivity.java

    1. CK CK

      @CK

      https://github.com/ckldev/BlockSecureFlag/releases/tag/v1.4

      1. 空zzzz 空zzzz

        @CK用不了,没效果惹

    2. CK CK

      @CK

      應該是SDK24/25
      8.0還未出XD

      1. @CK
        -.-
        我还是6.0呢

        1. CK CK

          @ilanyu

          呃..有空更新一下吧,我看7.0以上的手機也很多了xd

          1. @CK求更新支持7.1.2,真的很需要!

  7. 空zzzz 空zzzz

    更新了下1.4然而我小米miui9 7.0并用不了

    1. @空zzzz
      适配好7.0了

      1. 空zzzz 空zzzz

        @ilanyu谢谢

  8. 咸宁 咸宁

    作者可以适配下7.0吗,谢谢

    1. @咸宁
      适配好7.0了

  9. 雁闪雷冥 雁闪雷冥

    尊敬的作者,请问能烦劳适配一下7.0吗?目前1.3打开闪退,1.4无效果,您可以加上打赏功能,定会支持!谢谢。

    1. @雁闪雷冥
      适配好7.0了

  10. 空cccc 空cccc

    还是没有效果

  11. xtx85346 xtx85346

    Android7.1.2
    xposed 89
    SDK 25
    可以运行但无法起作用

    1. 空cccc 空cccc

      @xtx85346我还以为就我一个人没效果

    2. ???什么意思 ???什么意思

      @xtx85346去酷安下载,我已经可以用了

  12. 1069 1069

    作者大大有空再适配一下吧,谢谢

  13. 苏诺 苏诺

    开启QQ防截图后无法正常使用QQ了,希望大佬能够更新一下。

    1. ???什么意思 ???什么意思

      @苏诺去酷安下载1.2版本,7.0可用

  14. ACai ACai

    我想问,怎么用啊,哪个键+哪个键启用?

  15. w w

    您好博主 请问执行IntelliJIDEALicenseServer_linux_amd64一直报Bus error是怎么回事呢 我是centos6.5 64位

  16. 发条 发条

    请问用最新板的找到不到WindowManager.LayoutParams.FLAG_SECURE 是新版QQ隐藏了么?

  17. 白羊 白羊

    8.0的我该怎么办?

添加新评论